eZCom outage impacting Amazon Seller Central

Incident Report for Shipvine

Resolved

eZCom has restored services, but some orders may be delayed as they work through the backlog.
Posted Sep 17, 2025 - 16:56 EDT

Monitoring

eZCom has restored connectivity as of about 4:30 p.m. Eastern time, but is still working through some issues on their end. We'll work to help identify any missing orders as they fully restore services.
Posted Sep 17, 2025 - 16:43 EDT

Identified

eZCom, our underlying provider for Amazon Seller Central integrations, is experiencing a data center outage. Amazon Seller Central orders, inventory, and tracking numbers currently aren't syncing. They're aware of the issue and working to restore service.
Posted Sep 17, 2025 - 12:17 EDT
This incident affected: Sync.